Mercurial > cpython-lru_cache-weakref
annotate Doc/libwww.tex @ 5817:48b94de85bf3 legacy-trunk
Extensive changes by AMK.
| author | Guido van Rossum <guido@python.org> |
|---|---|
| date | Thu, 17 Jul 1997 16:29:42 +0000 |
| parents | 8b7face9b1a7 |
| children | 89771a46ca35 |
| rev | line source |
|---|---|
|
2609
7ef72873e4d6
restructured library manual accordiung to functional group
Guido van Rossum <guido@python.org>
parents:
2581
diff
changeset
|
1 \chapter{Internet and WWW Services} |
|
2581
4d28b655b728
added nodename macro calls for new very long section names
Guido van Rossum <guido@python.org>
parents:
2576
diff
changeset
|
2 \nodename{Internet and WWW} |
| 2355 | 3 \index{WWW} |
|
2576
f47bc5554418
mass changes; fix titles; add examples; correct typos; clarifications;
Guido van Rossum <guido@python.org>
parents:
2445
diff
changeset
|
4 \index{Internet} |
|
f47bc5554418
mass changes; fix titles; add examples; correct typos; clarifications;
Guido van Rossum <guido@python.org>
parents:
2445
diff
changeset
|
5 \index{World-Wide Web} |
| 2355 | 6 |
| 7 The modules described in this chapter provide various services to | |
| 8 World-Wide Web (WWW) clients and/or services, and a few modules | |
| 9 related to news and email. They are all implemented in Python. Some | |
| 10 of these modules require the presence of the system-dependent module | |
| 11 \code{sockets}, which is currently only fully supported on Unix and | |
| 12 Windows NT. Here is an overview: | |
| 13 | |
| 14 \begin{description} | |
| 15 | |
| 2445 | 16 \item[cgi] |
| 17 --- Common Gateway Interface, used to interpret forms in server-side | |
| 18 scripts. | |
| 19 | |
| 2355 | 20 \item[urllib] |
| 21 --- Open an arbitrary object given by URL (requires sockets). | |
| 22 | |
| 23 \item[httplib] | |
| 24 --- HTTP protocol client (requires sockets). | |
| 25 | |
| 26 \item[ftplib] | |
| 27 --- FTP protocol client (requires sockets). | |
| 28 | |
| 29 \item[gopherlib] | |
| 30 --- Gopher protocol client (requires sockets). | |
| 31 | |
| 32 \item[nntplib] | |
| 33 --- NNTP protocol client (requires sockets). | |
| 34 | |
| 35 \item[urlparse] | |
| 36 --- Parse a URL string into a tuple (addressing scheme identifier, network | |
| 37 location, path, parameters, query string, fragment identifier). | |
| 38 | |
|
4388
a77f4c22697f
(lib.tex, libwww.tex): Include the sgmlib chapter before the htmllib
Fred Drake <fdrake@acm.org>
parents:
4383
diff
changeset
|
39 \item[sgmllib] |
|
a77f4c22697f
(lib.tex, libwww.tex): Include the sgmlib chapter before the htmllib
Fred Drake <fdrake@acm.org>
parents:
4383
diff
changeset
|
40 --- Only as much of an SGML parser as needed to parse HTML. |
|
a77f4c22697f
(lib.tex, libwww.tex): Include the sgmlib chapter before the htmllib
Fred Drake <fdrake@acm.org>
parents:
4383
diff
changeset
|
41 |
| 2355 | 42 \item[htmllib] |
|
4383
e033c786f297
(libwww.tex): Added entry for formatter module.
Fred Drake <fdrake@acm.org>
parents:
2609
diff
changeset
|
43 --- A (slow) parser for HTML documents. |
| 2355 | 44 |
|
4383
e033c786f297
(libwww.tex): Added entry for formatter module.
Fred Drake <fdrake@acm.org>
parents:
2609
diff
changeset
|
45 \item[formatter] |
|
e033c786f297
(libwww.tex): Added entry for formatter module.
Fred Drake <fdrake@acm.org>
parents:
2609
diff
changeset
|
46 --- Generic output formatter and device interface. |
|
e033c786f297
(libwww.tex): Added entry for formatter module.
Fred Drake <fdrake@acm.org>
parents:
2609
diff
changeset
|
47 |
| 2355 | 48 \item[rfc822] |
| 49 --- Parse RFC-822 style mail headers. | |
| 50 | |
| 51 \item[mimetools] | |
| 52 --- Tools for parsing MIME style message bodies. | |
| 53 | |
|
4728
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
54 \item[binhex] |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
55 --- Encode and decode files in binhex4 format. |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
56 |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
57 \item[uu] |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
58 --- Encode and decode files in uuencode format. |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
59 |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
60 \item[binascii] |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
61 --- Tools for converting between binary and various ascii-encoded binary |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
62 representation |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
63 |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
64 \item[xdrlib] |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
65 --- The External Data Representation Standard as described in RFC 1014, |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
66 written by Sun Microsystems, Inc. June 1987. |
|
b218f294b726
(lib<all sorts of stuff>.tex):
Fred Drake <fdrake@acm.org>
parents:
4388
diff
changeset
|
67 |
|
5217
3ab7d58c2963
Added docs for mailcap
Guido van Rossum <guido@python.org>
parents:
4728
diff
changeset
|
68 \item[mailcap] |
|
3ab7d58c2963
Added docs for mailcap
Guido van Rossum <guido@python.org>
parents:
4728
diff
changeset
|
69 --- Mailcap file handling. See RFC 1524. |
|
3ab7d58c2963
Added docs for mailcap
Guido van Rossum <guido@python.org>
parents:
4728
diff
changeset
|
70 |
|
5344
9ca27188da23
Added fnmatch, base64 and quopri, received from Andrew Kuchling.
Guido van Rossum <guido@python.org>
parents:
5217
diff
changeset
|
71 \item[base64] |
|
9ca27188da23
Added fnmatch, base64 and quopri, received from Andrew Kuchling.
Guido van Rossum <guido@python.org>
parents:
5217
diff
changeset
|
72 --- Encode/decode binary files using the MIME base64 encoding. |
|
9ca27188da23
Added fnmatch, base64 and quopri, received from Andrew Kuchling.
Guido van Rossum <guido@python.org>
parents:
5217
diff
changeset
|
73 |
|
9ca27188da23
Added fnmatch, base64 and quopri, received from Andrew Kuchling.
Guido van Rossum <guido@python.org>
parents:
5217
diff
changeset
|
74 \item[quopri] |
|
9ca27188da23
Added fnmatch, base64 and quopri, received from Andrew Kuchling.
Guido van Rossum <guido@python.org>
parents:
5217
diff
changeset
|
75 --- Encode/decode binary files using the MIME quoted-printable encoding. |
|
9ca27188da23
Added fnmatch, base64 and quopri, received from Andrew Kuchling.
Guido van Rossum <guido@python.org>
parents:
5217
diff
changeset
|
76 |
|
5687
8b7face9b1a7
Added SocketServer and mailbox modules.
Guido van Rossum <guido@python.org>
parents:
5344
diff
changeset
|
77 \item[SocketServer] |
|
8b7face9b1a7
Added SocketServer and mailbox modules.
Guido van Rossum <guido@python.org>
parents:
5344
diff
changeset
|
78 --- A framework for network servers. |
|
8b7face9b1a7
Added SocketServer and mailbox modules.
Guido van Rossum <guido@python.org>
parents:
5344
diff
changeset
|
79 |
|
8b7face9b1a7
Added SocketServer and mailbox modules.
Guido van Rossum <guido@python.org>
parents:
5344
diff
changeset
|
80 \item[mailbox] |
|
8b7face9b1a7
Added SocketServer and mailbox modules.
Guido van Rossum <guido@python.org>
parents:
5344
diff
changeset
|
81 --- Read various mailbox formats. |
|
8b7face9b1a7
Added SocketServer and mailbox modules.
Guido van Rossum <guido@python.org>
parents:
5344
diff
changeset
|
82 |
| 2355 | 83 \end{description} |
