diff Lib/urlparse.py @ 61108:2d2a858fe3e1 legacy-trunk

Always add space after RFC; reword paragraph
author Andrew M. Kuchling <amk@amk.ca>
date Fri, 30 Apr 2010 00:49:09 +0000
parents 9dc864ef6425
children 06c6d3a67c17
line wrap: on
line diff
--- a/Lib/urlparse.py	Thu Apr 29 20:31:17 2010 +0000
+++ b/Lib/urlparse.py	Fri Apr 30 00:49:09 2010 +0000
@@ -8,21 +8,22 @@
 RFC 2732 : "Format for Literal IPv6 Addresses in URL's by R.Hinden, B.Carpenter
 and L.Masinter, December 1999.
 
-RFC2396:  "Uniform Resource Identifiers (URI)": Generic Syntax by T.
+RFC 2396:  "Uniform Resource Identifiers (URI)": Generic Syntax by T.
 Berners-Lee, R. Fielding, and L. Masinter, August 1998.
 
-RFC2368: "The mailto URL scheme", by P.Hoffman , L Masinter, J. Zwinski, July 1998.
+RFC 2368: "The mailto URL scheme", by P.Hoffman , L Masinter, J. Zwinski, July 1998.
 
 RFC 1808: "Relative Uniform Resource Locators", by R. Fielding, UC Irvine, June
 1995.
 
-RFC1738: "Uniform Resource Locators (URL)" by T. Berners-Lee, L. Masinter, M.
+RFC 1738: "Uniform Resource Locators (URL)" by T. Berners-Lee, L. Masinter, M.
 McCahill, December 1994
 
-RFC 3986 is considered the current standard and any changes to urlparse module
-should conform to this.  urlparse module is not entirely compliant with this.
-The defacto scenarios of parsing are considered sometimes and for backward
-compatiblity purposes, older RFC uses of parsing are retained. The testcases in
+RFC 3986 is considered the current standard and any future changes to
+urlparse module should conform with it.  The urlparse module is
+currently not entirely compliant with this RFC due to defacto
+scenarios for parsing, and for backward compatibility purposes, some
+parsing quirks from older RFCs are retained. The testcases in
 test_urlparse.py provides a good indicator of parsing behavior.
 
 """