| Thu, 24 May 2012 21:54:34 +0800 |
Senthil Kumaran |
Issue #14036: return None when port in urlparse cross 65535
2.7
|
| Sat, 19 May 2012 17:12:17 +0300 |
Ezio Melotti |
#14072: Fix parsing of tel URIs in urlparse by making the check for ports stricter.
2.7
|
| Sat, 19 May 2012 08:10:40 +0800 |
Senthil Kumaran |
Issue9374 - Generic parsing of query and fragment portion of urls for any scheme
2.7
|
| Wed, 19 Oct 2011 10:39:35 +0300 |
Ezio Melotti |
Remove duplication.
2.7
|
| Wed, 03 Aug 2011 22:06:05 +0800 |
Senthil Kumaran |
add svn+ssh testcase for urljoin.
2.7
|
| Wed, 03 Aug 2011 18:31:59 +0800 |
Senthil Kumaran |
Fix closes issue12683 - urljoin to work with relative join of svn scheme.
2.7
|
| Sat, 23 Jul 2011 18:41:43 +0800 |
Senthil Kumaran |
merge from 3.2 - Fix closes issue12581 - Increase the urllib.parse test coverage (cases applicable to 2.7). Patch by Petter Haggholm.
2.7
|
| Fri, 15 Apr 2011 18:07:33 +0800 |
Senthil Kumaran |
Issue #11467: Fix urlparse behavior when handling urls which contains scheme
2.7
|
| Sat, 05 Mar 2011 15:15:07 +0100 |
Georg Brandl |
Dummy-merge 2.6 branch into 2.7 branch.
2.7
|
| Fri, 17 Dec 2010 04:56:02 +0000 |
Senthil Kumaran |
Merged revisions 87329 via svnmerge from
2.7
|
| Wed, 04 Aug 2010 04:45:31 +0000 |
Senthil Kumaran |
Fix Issue754016 - urlparse goes wrong with IP:port without scheme
2.7
|
| Wed, 14 Jul 2010 10:39:35 +0000 |
Senthil Kumaran |
Merged revisions 82881 via svnmerge from
2.7
|
| Thu, 13 May 2010 03:25:21 +0000 |
Senthil Kumaran |
Fix Issue8657 - adding git and git+ssh as know schemes.
legacy-trunk
|
| Fri, 07 May 2010 04:07:29 +0000 |
Senthil Kumaran |
Testsuite for RFC3986 based parsing scenario. Related Issue1462525.
legacy-trunk
|
| Thu, 22 Apr 2010 12:10:13 +0000 |
Senthil Kumaran |
Changed tests to only urlparse one, which was enough, addressed Ezio's comment
legacy-trunk
|
| Tue, 20 Apr 2010 20:37:59 +0000 |
Senthil Kumaran |
Issue2987 - Added additional Invalid URL and changed the Invalid URL checking code for better.
legacy-trunk
|
| Fri, 16 Apr 2010 02:46:46 +0000 |
Senthil Kumaran |
Fix issue2987: RFC2732 support for urlparse (IPv6 addresses)
legacy-trunk
|
| Mon, 12 Apr 2010 06:50:24 +0000 |
Senthil Kumaran |
Adding additional examples of valid urls as per RFC 3986 (for issue8339)
legacy-trunk
|
| Fri, 19 Feb 2010 07:32:48 +0000 |
Senthil Kumaran |
Fix for Issue7904. urlparse.urlsplit to handle schemes in the way defined by RFC3986
legacy-trunk
|
| Mon, 30 Mar 2009 21:51:50 +0000 |
Senthil Kumaran |
Fix for bugs: Issue4675 and Issue4962.
legacy-trunk
|
| Sat, 05 Mar 2011 15:13:50 +0100 |
Georg Brandl |
Dummy-merge 2.5 branch into 2.6 branch.
2.6
|
| Wed, 14 Jul 2010 10:58:12 +0000 |
Senthil Kumaran |
Merged revisions 82883 via svnmerge from
2.6
|
| Thu, 13 May 2010 03:32:26 +0000 |
Senthil Kumaran |
Merged revisions 81130 via svnmerge from
2.6
|
| Fri, 07 May 2010 04:15:56 +0000 |
Senthil Kumaran |
Merged revisions 80908 via svnmerge from
2.6
|
| Mon, 12 Apr 2010 06:56:24 +0000 |
Senthil Kumaran |
Merged revisions 79988 via svnmerge from
2.6
|
| Fri, 19 Feb 2010 07:39:41 +0000 |
Senthil Kumaran |
Merged revisions 78234 via svnmerge from
2.6
|
| Wed, 03 Sep 2008 22:35:50 +0000 |
Facundo Batista |
Issue 600362: Relocated parse_qs() and parse_qsl(), from the cgi module
legacy-trunk
|
| Thu, 14 Aug 2008 16:51:00 +0000 |
Facundo Batista |
Issue 1432. Fixes a bug caused because of the evolution
legacy-trunk
|
| Sat, 05 Jan 2008 22:19:06 +0000 |
Guido van Rossum |
Patch #1637: fix urlparse for URLs like 'http://x.com?arg=/foo'.
legacy-trunk
|
| Sat, 05 Jan 2008 15:13:49 +0000 |
Andrew M. Kuchling |
Fix comment typo
legacy-trunk
|
| Sat, 05 Jan 2008 04:38:38 +0000 |
Fred Drake |
clean up a comment
legacy-trunk
|
| Sat, 05 Jan 2008 01:21:57 +0000 |
Guido van Rossum |
Patch #1698 by Senthil: allow '@' in username when parsed by urlparse.py.
legacy-trunk
|
| Sat, 05 Jan 2008 23:34:38 +0000 |
Guido van Rossum |
Backport r59758.
2.5
|
| Thu, 13 Dec 2007 18:18:47 +0000 |
Alexandre Vassalotti |
Backport r59480.
2.5
|
| Sat, 01 Apr 2006 22:14:43 +0000 |
Fred Drake |
Patch #624325: urlparse.urlparse() and urlparse.urlsplit() results
legacy-trunk
|
| Fri, 29 Jul 2005 15:57:59 +0000 |
Fred Drake |
add support for svn: and svn+ssh: URL schemes to urlparse
2.4
|
| Sun, 09 Jan 2005 15:32:37 +0000 |
Johannes Gijsbers |
Backport patch #712317: In URLs such as http://www.example.com?query=spam,
2.4
|
| Sun, 12 Oct 2003 04:29:10 +0000 |
Brett Cannon |
see rev. 1.13 for log message
legacy-trunk
|
| Mon, 06 Jan 2003 20:27:03 +0000 |
Skip Montanaro |
* add mms (windows media) as another scheme
legacy-trunk
|
| Mon, 06 Jan 2003 06:58:31 +0000 |
Neal Norwitz |
SF feature #618024, urlparse fails on imap://
legacy-trunk
|
| Wed, 16 Oct 2002 21:02:36 +0000 |
Fred Drake |
Make sure we test urlsplit() / urlunsplit() directly, rather than
legacy-trunk
|
| Mon, 14 Oct 2002 19:59:54 +0000 |
Guido van Rossum |
Fix for 1.33: urlsplit() should only add '//' if scheme != ''.
legacy-trunk
|
| Wed, 25 Sep 2002 19:20:12 +0000 |
Neal Norwitz |
Fix SF # 591713, Fix "file:" URL to have right no. of /'s, by Bruce Atherton
legacy-trunk
|
| Tue, 23 Jul 2002 19:04:11 +0000 |
Barry Warsaw |
Get rid of relative imports in all unittests. Now anything that
legacy-trunk
|
| Tue, 16 Apr 2002 01:38:40 +0000 |
Tim Peters |
Whitespace normalization.
legacy-trunk
|
| Sat, 23 Mar 2002 05:32:10 +0000 |
Skip Montanaro |
added RFC 2396 tests from Aaron Swartz included in bug # 450225.
legacy-trunk
|
| Mon, 14 Oct 2002 20:08:50 +0000 |
Guido van Rossum |
Backporting urlparse.py:1.34, test_urlparse.py:1.8:
2.2
|
| Mon, 07 Oct 2002 01:18:17 +0000 |
Tim Peters |
Whitespace normalization.
2.2
|
| Wed, 25 Sep 2002 19:22:10 +0000 |
Neal Norwitz |
Backport:
2.2
|
| Mon, 18 Mar 2002 13:03:40 +0000 |
Michael W. Hudson |
amk's fix attached to
2.2
|
| Fri, 05 Jan 2001 05:57:04 +0000 |
Fred Drake |
Add test cases based on RFC 1808. So now we actually have a test suite
legacy-trunk
|
| Thu, 03 Aug 2000 17:28:50 +0000 |
Moshe Zadka |
Checking in empty tests for urlparse, as future place holders
legacy-trunk
|