Mercurial > cpython-lru_cache-weakref
changeset 60655:2938bf899863 2.6
Merged revisions 80146 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
........
r80146 | senthil.kumaran | 2010-04-17 20:00:53 +0530 (Sat, 17 Apr 2010) | 3 lines
Fix Issue5650 - Update the RFC List in the urlparse module.
........
| author | Senthil Kumaran <orsenthil@gmail.com> |
|---|---|
| date | Sat, 17 Apr 2010 14:33:55 +0000 |
| parents | 68fd70a9e77a |
| children | ea42af968d9d |
| files | Lib/urlparse.py |
| diffstat | 1 files changed, 25 insertions(+), 2 deletions(-) [+] |
line wrap: on
line diff
--- a/Lib/urlparse.py Fri Apr 16 23:00:54 2010 +0000 +++ b/Lib/urlparse.py Sat Apr 17 14:33:55 2010 +0000 @@ -1,7 +1,30 @@ """Parse (absolute and relative) URLs. -See RFC 1808: "Relative Uniform Resource Locators", by R. Fielding, -UC Irvine, June 1995. +urlparse module is based upon the following RFC specifications. + +RFC 3986 (STD66): "Uniform Resource Identifiers" by T. Berners-Lee, R. Fielding +and L. Masinter, January 2005. + +RFC 2732 : "Format for Literal IPv6 Addresses in URL's by R.Hinden, B.Carpenter +and L.Masinter, December 1999. + +RFC2396: "Uniform Resource Identifiers (URI)": Generic Syntax by T. +Berners-Lee, R. Fielding, and L. Masinter, August 1998. + +RFC2368: "The mailto URL scheme", by P.Hoffman , L Masinter, J. Zwinski, July 1998. + +RFC 1808: "Relative Uniform Resource Locators", by R. Fielding, UC Irvine, June +1995. + +RFC1738: "Uniform Resource Locators (URL)" by T. Berners-Lee, L. Masinter, M. +McCahill, December 1994 + +RFC 3986 is considered the current standard and any changes to urlparse module +should conform to this. urlparse module is not entirely compliant with this. +The defacto scenarios of parsing are considered sometimes and for backward +compatiblity purposes, older RFC uses of parsing are retained. The testcases in +test_urlparse.py provides a good indicator of parsing behavior. + """ __all__ = ["urlparse", "urlunparse", "urljoin", "urldefrag",
